Having some issues with a collection that works in silverlight

Jul 1, 2012 at 10:08 PM

Hi, 

I've been playing around with the lobsterpot html5 pivot viewer.  I'd love to use it instead of the silverlight control but I'm running into some rendering issues and was hoping someone could help.

Take a look at: http://www.hockeyshuffle.com/lobsterpot.  The control loads find, but none of the images do.  Also, the filter facets in the left pane don't expand properly.

You can see what the collection is supposed to look like here: http://www.hockeyshuffle.com/collections/NHL-Regular-Season-2012

Is there something wrong with my collection?  Any insight you can give would be greatly appreciated!

Coordinator
Jul 2, 2012 at 10:31 AM

Hi,

I've downloaded a copy of the cxml and dz files and I've managed to reproduce the problems you are having.

The problem with the images is that the id's in the CXML don't match up with the id's in the dzc (f7512e8470894172aa2bc2ee16af2af6\i\c.xml) - was the collection generated with the excel addin?

The HTML PV uses the Item Id to then match the I Id in the dzc which at the moment don't match up.

For example the CXML Item with the Id="00000000" should match up with an I Id="00000000" in the dzc. 

I'm going to have a closer look at the spec to work out if I'm doing it wrong, and then have a look at fixing it.

I'm also not sure yet what is going on with the left hand menu - I'll keep you posted when I know more.

Roger

Coordinator
Jul 4, 2012 at 11:50 AM

Hi mvbrocato,

I've just created release 0.6.7 which should fix the issues you are having with the collection images.

It seems the problems with the filter panel are to do with the amount of items it can display - this is something I still need to fix. To get around it in your collection you can include the IsFilterVisible="false" attribute on the FacetCategories you want to hide from the filter panel, you can also hide all Link and DateTime types as they are currently not supported. For example:

<FacetCategory Name="url" Type="Link" p:IsFilterVisible="false"/>

I hope that at least makes your collection usable until the other issues get resolved.

 

Roger

Jul 6, 2012 at 12:31 AM

Hi Roger, 

Thank you for looking into this.  I updated my site to the latest version of the pivotviewer today.  I now see the images, but the bad news is they don't match up with the players.  It seems like this is a problem with every player, not just a select few.  Also, I noticed two more things:  (1)  Numeric filters don't have those neat little column graphs like in the Silverlight control, is that not implemented yet or am I seeing a bug?  (2) All of my numeric filters seem to be capped at 99, even when there are values above 99.

You can see this behavior here: http://www.hockeyshuffle.com/lobsterpot

Coordinator
Jul 6, 2012 at 12:51 AM

Hi,

Yes I've seen the problem with the Numeric facets in your collection, it's a bug that I'll have to investigate.

Not sure why the images are not being matched correctly, unfortunately I'm not familiar enough with hockey to know where the matching problems are.

 

Roger

Coordinator
Jul 11, 2012 at 10:50 AM

Hi Again,

You'll be please to know that the latest release (0.6.8) has resolved the issue with Numeric facets.

I'm still unsure what the issue is with the tile images not matching the items - are you able to give me an example from your collection of a player that does not match their description?

Roger

Jul 14, 2012 at 11:19 PM

Thanks for the update.  I can confirm that the numeric facets are much improved.  I noticed a few minor issues with 0.6.8:

1.)  When you start filtering by a numeric facet, applying an upper or lower bound, this displays a label above the column chart which pushes the column chart down.  The silverlight control leaves space for this label and thus the chart remains in the same place when it is displayed.

2.) When you constrain the upper or lower bounds using the slider, the columns in the chart do not gray out as they do with the silverlight control.

Again, these are very minor, but I figured I'd point them out as I'm sure they are easy to fix.

I did notice as well that the search box doesn't seem to work on my collection.  I tried for example searching for a player by name and nothing happened.  Not sure if it makes a difference but I am using Chrome 20.0.1132.57 on Mac OS.  Also, if I look at my activity monitor, my chrome window seems to be pegged at 100% CPU when I have the pivotviewer open.

Regarding the mismatched images, if you sort the collection by player_id, I think the problem is revealed - it looks like the control is truncating the rightmost digit in the player_id, resulting in multiple players sharing the same image.  I hope this helps.  I've updated the site with 0.6.8 >> http://www.hockeyshuffle.com/lobsterpot.

Thanks again!

Mark

Oct 31, 2012 at 2:37 AM

Hi everyone,

Roger, first of all thank you for this amazing work and the contribution to the open-source community.

Problem: I have similar problems with the images of the controls. The red "clear" button (image) does not show up in any of the facet categories in the filter panel. The same is true for the graph view and the grid view image. However, LobsterPot logo is shown in the left hand corner as (i guess it is) brand image of the collection.

Environment: I'm using firefox 16.0.2 and your example collection of PASS Summit 2011 offline.

Any idea what produces this kind of problem? (I'm a newbie to jQuery and js but I'll have a look into it when you can point a rough direction.)

 

Besides: I had a minor issue searching for information ("StreamInsight") as part of the description of an item because it could not be found in your example collection.

 

Best Regards,

 

Felix

Coordinator
Oct 31, 2012 at 2:45 AM

Hi Felix,

The missing images are most likely due to the path in the pivotviewer.css file being incorrect for your environment. You'll just have to update the path - look for: background-image: url('../Content/images/FilterPanelClear.png');

Thanks for letting me know about the collection, I had a clean up on the host recently and deleted it without realising.

Values in the description are not currently searchable, but that would be a useful feature.

Thanks

Roger